DOCman 2.1 to DOCman 3

If you are unsure about the upgrade or have questions related to your setup, you can contact us and we can make sure everything is in order together.

Requirements

  • Joomla 3.6.x or later
  • DOCman 2.1, check our upgrading guides when running an older version

How it works

1. Check the changelog

We have added a dozen of new features to DOCman 3 but also removed a few. Make sure to check the changelog before upgrading.

2. Backup, the backup

Before you start the upgrade process please make a full backup of your site. If you have private documents, make sure you site is offline or make a copy of your site where you can work in.

3. Install the DOCman package

Download the latest DOCman package from our Support Center.

Upgrading to DOCman 3 is done via the standard Joomla extension installer. Navigate to Extensions > Manage > Install. Then select the Upload Package File tab.

Earlier versions of DOCman required our extension manager EXTman. This is no longer the case. EXTman is automatically uninstalled during the installation of DOCman 3.

4. Upgrade FILEman & LOGman (optional)

Also install the latest FILEman & LOGman packages if you use them on your site.

Since all our extensions share a common base framework your site might stop functioning if you don’t upgrade all extensions together.